I've built my Gigatron

A place to eternalise your Gigatron build photos. From box to BASIC.
Forum rules
Use this forum to show off your build photos. For build issues, please consult the directions in the sticky post on top instead.
Post Reply
kopizoli
Posts: 3
Joined: 16 May 2021, 08:56

I've built my Gigatron

Post by kopizoli »

First of all I would like to congratulate to the founders of Gigatron (I know that Marcel has passed in last year :-() and say thank you that they’ve shared it and made it open source.
About a year ago, my younger brother sent me a link about Gigatron, the official website. From that time I’ve decided that I will build one for myself. :-) Approx. 2-3 months ago, I’ve started to order the PCB of Gigatron, simultaneously the Pluggy McPlugface’s PCB and the electronic parts. The hardest part was the 6.25 MHz crystal, which I found only at Mouser, so I’ve ordered it from there, together with some other parts. If I build an electronic with ICs, I always use IC sockets, because it makes easier if any of the ICs need to be changed. Also, I’ve found a picture somewhere that someone has used a 40-pin ZIF socket for the EPROM IC in order to easier remove the IC and reprogram it with a newer firmware, so I also ordered a 40-pin ZIF socket. When all the parts have arrived, I’ve started to build it. There were some challenges, the first time, it didn’t start, sometimes all the four LEDs were lighting and sometimes, random 2-3-4 pcs. Finally, I found the problem, and fixed it.
To find a proper wooden box was also a challenge, I’ve tried to find a similar size than the main PCB. Finally, I found a good one, but I had to remove the separators from it and it was a nature wood, so I’ve used a spot-glaze 2 times and used one layer of varnish. Certainly, I had to drill and cut the backside of it for the connectors. For keeping the PCB in the wood box, I’ve used 4 pcs Nylon Hex spacers which I glued to the bottom of the box.
Last, but not least, I’ve assembled the Pluggy McPlugface which certainly didn’t work on the first time. I had the same issue which Aaron had in last November (viewtopic.php?f=3&t=272), when I attached a PS/2 keyboard, Gigatron had recognize it, the lights were up, but none of the buttons worked, only sometimes, if I pushed a bunch of buttons, Snake were started. The problem was that when I programmed the ATTiny85 with my TL866 II Plus EPROM burner, I didn’t change the Fuse Low Byte to the proper value. When I fixed this mistake, my PS/2 keyboard with the Pluggy McPlugface interface worked like a charm.
I’m still waiting for the delivery of the gamepad from Aliexpress, but until that, I can use the PS/2 keyboard instead.
The future plan is to extend it to 128kb with the RAM & IO Expansion board, I’ve already ordered the PCB from China.
Attachments
20210510_174542_small.jpg
20210510_174542_small.jpg (129.28 KiB) Viewed 789 times
20210502_202954_small.jpg
20210502_202954_small.jpg (199.56 KiB) Viewed 789 times
20210502_202939_small.jpg
20210502_202939_small.jpg (165.15 KiB) Viewed 789 times
20210502_192611_small.jpg
20210502_192611_small.jpg (207.06 KiB) Viewed 789 times
20210502_174529_small.jpg
20210502_174529_small.jpg (201.39 KiB) Viewed 789 times
20210429_203752_small.jpg
20210429_203752_small.jpg (185.86 KiB) Viewed 789 times
20210427_200742_small.jpg
20210427_200742_small.jpg (159.92 KiB) Viewed 789 times
20210427_200710_small.jpg
20210427_200710_small.jpg (199 KiB) Viewed 789 times
20210427_192521_small.jpg
20210427_192521_small.jpg (201.33 KiB) Viewed 789 times
20210427_184713_small.jpg
20210427_184713_small.jpg (205.44 KiB) Viewed 789 times
kopizoli
Posts: 3
Joined: 16 May 2021, 08:56

Re: I've built my Gigatron

Post by kopizoli »

And some more pictures :
Attachments
20210515_203623_small.jpg
20210515_203623_small.jpg (70.38 KiB) Viewed 784 times
20210515_203600_small.jpg
20210515_203600_small.jpg (90.52 KiB) Viewed 784 times
20210515_203103_small.jpg
20210515_203103_small.jpg (87.03 KiB) Viewed 784 times
20210515_203052_small.jpg
20210515_203052_small.jpg (148.42 KiB) Viewed 784 times
20210515_203008_small.jpg
20210515_203008_small.jpg (87.96 KiB) Viewed 784 times
20210515_202954_small.jpg
20210515_202954_small.jpg (148.31 KiB) Viewed 784 times
20210510_174626_small.jpg
20210510_174626_small.jpg (115.37 KiB) Viewed 784 times
20210510_174600_small.jpg
20210510_174600_small.jpg (196.74 KiB) Viewed 784 times
Vyvvyan
Posts: 6
Joined: 14 May 2018, 01:03

Re: I've built my Gigatron

Post by Vyvvyan »

Excellent, very nice, looks very much like an original Gigatron in that box!
kopizoli
Posts: 3
Joined: 16 May 2021, 08:56

Re: I've built my Gigatron

Post by kopizoli »

Vyvvyan wrote: 23 May 2021, 02:55 Excellent, very nice, looks very much like an original Gigatron in that box!
Thank you. :-)
Post Reply