Page 1 of 1

Keyboard not always recognized.

Posted: 04 Mar 2019, 08:45
by Gigadave
Hi,

50% of the time when I power up my Gigatron it wont recognize the keyboard and I have to unplug and plug back in a couple of times.
I have tried different PS/2 keyboards but they all do the same thing.
Is this the Pluggy McPlugface adapter ?, for example firmware on the PIC ?

Is anyone else having this problem ?

Thanks

Re: Keyboard not always recognized.

Posted: 04 Mar 2019, 09:37
by Gigadave
I found an old IBM keyboard that doesn't have the problem.
It works every time I turn on the Gigatron.
It seams there might be some compatibility problems with later keyboards.
Some work better than others.

Re: Keyboard not always recognized.

Posted: 04 Mar 2019, 10:13
by marcelk
During startup some keyboards draw much more current than others, and therefore can have difficulty to boot. Sometimes replacing the USB cable or power supply can mitigate the issue to some extent, but not always. Also see viewtopic.php?f=3&t=74

Re: Keyboard not always recognized.

Posted: 05 Mar 2019, 08:08
by Gigadave
I had a spare official Raspberry Pi power supply that is rated at 5.1v 2.5amp and now all my PS/2 keyboards without an issue.
Also I'm using a heavier, shorter Mini USB Cable.

Re: Keyboard not always recognized.

Posted: 06 Mar 2019, 01:31
by jbailey
I had issues too, it found that a higher amperage rated USB cord solved my problems too. I found that many USB/PS2 keyboards are using very minimal cable. So when both are paired together you get a lot of DC loss. One or the other is fine but both together were causing my issues.