Another successful Gigatron build

A place to eternalise your Gigatron build photos. From box to BASIC.
Forum rules
Use this forum to show off your build photos. For build issues, please consult the directions in the sticky post on top instead.
Post Reply
denjhang
Posts: 50
Joined: 02 May 2021, 01:25
Location: yuenan
Contact:

Another successful Gigatron build

Post by denjhang »

:D I changed the NES controller to famiclone for Gigatron compatibility
Image
Image
bmwtcu
Posts: 132
Joined: 01 Nov 2018, 12:02

Re: Another successful Gigatron build

Post by bmwtcu »

Congrats! Is this the same unit you were debugging earlier? If so, I'm curious what was the issue with the board that prevented it from working?
denjhang
Posts: 50
Joined: 02 May 2021, 01:25
Location: yuenan
Contact:

Re: Another successful Gigatron build

Post by denjhang »

bmwtcu wrote: 30 Jan 2022, 14:18 Congrats! Is this the same unit you were debugging earlier? If so, I'm curious what was the issue with the board that prevented it from working?
The story is twisty. I've been asking for help since my failure last May. Aside from me, at least two people have experienced similar failures. It was actually only recently built, thanks to a friend of mine who was interested in Gigatron.
All I can confirm is that all my ROMs are available, but some RAM is not available. For example, AS6C62256-70, UT62256-70, HM62256LP-12 are all available. However HM62256-15 and UM62256-70 are not available.
By the way, I couldn't buy a 6.25MHZ crystal, I used a minimax 8085's 6.144MHZ crystal instead.
The dramatic thing is that recently I built a project similar to gigatron: Minimal UART CPU, this one also doesn't seem to work correctly (serial port receives garbled characters)
klf
Posts: 17
Joined: 10 Jan 2019, 22:48

Re: Another successful Gigatron build

Post by klf »

denjhang wrote: 30 Jan 2022, 14:31 All I can confirm is that all my ROMs are available, but some RAM is not available. For example, AS6C62256-70, UT62256-70, HM62256LP-12 are all available. However HM62256-15 and UM62256-70 are not available.
HM62256-15 is too slow, you need 70ns. HM62256LP-12 is also too slow, you were lucky that it works.

UM62256-70 does not like /CE tied permanently low.
denjhang
Posts: 50
Joined: 02 May 2021, 01:25
Location: yuenan
Contact:

Re: Another successful Gigatron build

Post by denjhang »

Another reason may be that I used a poor quality round hole IC socket, resulting in poor contact. This problem was encountered when I was building an Omega MSX2+.
Maybe my HM62256-15 and UM62256-70 are broken chips as they don't work in any other project.
Post Reply